Library / Windows

vmwp.exe

Virtual Machine Worker Process · Microsoft Corporation

WindowsParsed

OriginalFilename

  • vmwp.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\vmwp.exe'
    - OriginalFileName: 'vmwp.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
vmwp.exe1x6410.0.26100.9711Host scan

InternalName: Virtual Machine Worker Process · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
ad1d4d5380f8…10.0.26100.9711x64vmwp.exeHost scan

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.