Library / Sysinternals

volumeid.exe

Set disk volume id · Sysinternals - www.sysinternals.com

SysinternalsSysmon-confirmedSigma refs: 1

OriginalFilename

  • volumeid.exe

Shared with other binaries

Gotchas

  • Same OriginalFilename as volumeid64.exe, so OriginalFilename alone can't tell them apart.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\volumeid.exe'
    - OriginalFileName: 'volumeid.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
volumeid.exe1x862.1.0.0Sysinternals✓ 1

InternalName: VolumeId · Product: Sysinternals VolumeId

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
22a2484d7fa7…2.1.0.0x86volumeid.exeSysinternals VolumeIdSysinternals✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.