Library / LOLBin

vsdiagnostics.exe

VSDiagnostics · Microsoft Corporation

LOLBinWindowsParsedLOLBASSigma refs: 1

OriginalFilename

  • VSDiagnostics.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\vsdiagnostics.exe'
    - OriginalFileName: 'VSDiagnostics.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
VSDiagnostics.exe1x8617.14.37813.3Host scan

InternalName: VSDiagnostics.exe · Product: Microsoft® Visual Studio®

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
05c726932b4e…17.14.37813.3x86VSDiagnostics.exeHost scan

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.