Library / Windows

w32tm.exe

Windows Time Service Diagnostic Tool · Microsoft Corporation

WindowsSysmon-confirmedSigma refs: 1

OriginalFilename

  • w32time.dll

Differs from file nameNames a DLL

Gotchas

  • OriginalFilename names a DLL (w32time.dll), not an executable. Rules expecting .exe values miss it.
  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: w32tm.exe never fires.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\w32tm.exe'
    - OriginalFileName: 'w32time.dll'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
w32time.dll14x64, x8610.0.10240.16384 → 10.0.28000.2804Win10 1507 → Win11 26H1 (7)Host scan, Winbindex✓ 2

InternalName: w32time.dll · Product: Microsoft® Windows® Operating System

All 14 parsed builds · 26 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
3fa10d25d98d…10.0.28000.2804x64w32time.dllWin11 26H1UnsignedWinbindex
37f8056ad80c…10.0.28000.2804x86w32time.dllWin11 26H1UnsignedWinbindex
6aec23acacd5…10.0.26100.9549x86w32time.dllWin11 24H2UnsignedHost scan, Winbindex✓
4f5d676f3635…10.0.26100.9549x64w32time.dllWin11 24H2UnsignedHost scan, Winbindex✓
496e0dfd222d…10.0.26100.4202x64w32time.dllWin11 24H2, Win11 25H2UnsignedWinbindex
2920e8df32e1…10.0.26100.4202x86w32time.dllWin11 24H2, Win11 25H2UnsignedWinbindex
c71b4316bf6e…10.0.17763.719x64w32time.dllWin10 1809UnsignedWinbindex
b98bde1672d5…10.0.17763.719x86w32time.dllWin10 1809UnsignedWinbindex
c879ce7de155…10.0.14393.0x86w32time.dllWin10 1607UnsignedWinbindex
6b71a1db48da…10.0.14393.0x64w32time.dllWin10 1607UnsignedWinbindex
f21dda9313c4…10.0.10586.0x64w32time.dllWin10 1511UnsignedWinbindex
2f1016122024…10.0.10586.0x86w32time.dllWin10 1511UnsignedWinbindex
7481b61d95c4…10.0.10240.16384x64w32time.dllWin10 1507UnsignedWinbindex
0c5aba74f772…10.0.10240.16384x86w32time.dllWin10 1507UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.