Library / Windows

w3wp.exe

IIS Worker Process · Microsoft Corporation

WindowsParsedSigma refs: 15

OriginalFilename

  • w3wp.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\w3wp.exe'
    - OriginalFileName: 'w3wp.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
w3wp.exe6x64, x8610.0.22000.708 → 10.0.28000.1Win11 21H2 → Win11 26H1 (3)Winbindex

InternalName: w3wp.exe · Product: Internet Information Services

All 6 parsed builds · 2 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
9b177dadd09f…10.0.28000.1x64w3wp.exeWin11 26H1UnsignedWinbindex
6f512a160409…10.0.28000.1x86w3wp.exeWin11 26H1UnsignedWinbindex
d107fbbce897…10.0.26100.1882x64w3wp.exeWin11 24H2UnsignedWinbindex
7fd4a4ef102b…10.0.26100.1882x86w3wp.exeWin11 24H2UnsignedWinbindex
dc3dfc6c781c…10.0.22000.708x64w3wp.exeWin11 21H2UnsignedWinbindex
20a17637e5bc…10.0.22000.708x86w3wp.exeWin11 21H2UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.