Library / Windows

waitfor.exe

waitfor - wait/send a signal over a network · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • waitfor.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\waitfor.exe'
    - OriginalFileName: 'waitfor.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
waitfor.exe2x64, x8610.0.26100.1Host scan✓ 2

InternalName: waitfor.exe · Product: Microsoft® Windows® Operating System

All 2 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
bc8068165f87…10.0.26100.1x86waitfor.exeHost scan✓
62c5818d2480…10.0.26100.1x64waitfor.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.