Library / Windows

wcsetupagent.exe

Utility VM Setup Agent · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • wcsetupagent.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\wcsetupagent.exe'
    - OriginalFileName: 'wcsetupagent.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
wcsetupagent.exe1x6410.0.26100.9278Host scan✓ 1

InternalName: wcsetupagent.exe · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
6d10214ac0f3…10.0.26100.9278x64wcsetupagent.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.