Library / Windows

wecutil.exe

Event Collector Command Line Utility · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • WECUTIL.EXE

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\wecutil.exe'
    - OriginalFileName: 'WECUTIL.EXE'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
WECUTIL.EXE2x64, x8610.0.26100.9168 → 10.0.26100.9549Host scan✓ 2

InternalName: WECUTIL.EXE · Product: Microsoft® Windows® Operating System

All 2 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
e2b4913c6491…10.0.26100.9549x64WECUTIL.EXEHost scan✓
2b0d622a9d62…10.0.26100.9168x86WECUTIL.EXEHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.