Library / Windows

wextract.exe

Win32 Cabinet Self-Extractor · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • WEXTRACT.EXE

Differs from file name

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: wextract.exe never fires.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\wextract.exe'
    - OriginalFileName: 'WEXTRACT.EXE            '
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
WEXTRACT.EXE 2x64, x8611.0.26100.9549Host scan✓ 2

InternalName: Wextract · Product: Internet Explorer

All 2 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
62b8e323fc7d…11.0.26100.9549x86WEXTRACT.EXE Host scan✓
2e3ddd1019a1…11.0.26100.9549x64WEXTRACT.EXE Host scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.