Library / Windows

whoami.exe

whoami - displays logged on user information · Microsoft Corporation

WindowsSysmon-confirmedSigma refs: 17

OriginalFilename

  • whoami.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\whoami.exe'
    - OriginalFileName: 'whoami.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
whoami.exe10x64, x8610.0.10240.16384 → 10.0.26100.1882Win10 1507 → Win11 25H2 (6)Host scan, Winbindex✓ 2

InternalName: whoami.exe · Product: Microsoft® Windows® Operating System

All 10 parsed builds · 26 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
bf803e9a7a7f…10.0.26100.1882x86whoami.exeWin11 24H2, Win11 25H2Signed (Catalog file)Host scan, Winbindex✓
23240ef9f8b0…10.0.26100.1882x64whoami.exeWin11 24H2, Win11 25H2Signed (Catalog file)Host scan, Winbindex✓
6c7c2450a80f…10.0.16299.15x64whoami.exeWin10 1709UnsignedWinbindex
26d64193736e…10.0.16299.15x86whoami.exeWin10 1709UnsignedWinbindex
8ecffcce38d4…10.0.14393.0x64whoami.exeWin10 1607UnsignedWinbindex
72c2b9733d3d…10.0.14393.0x86whoami.exeWin10 1607UnsignedWinbindex
3b5efc1fceff…10.0.10586.0x64whoami.exeWin10 1511UnsignedWinbindex
18b9b2edd0ca…10.0.10586.0x86whoami.exeWin10 1511UnsignedWinbindex
8fbdc065f908…10.0.10240.16384x64whoami.exeWin10 1507UnsignedWinbindex
54e26855769e…10.0.10240.16384x86whoami.exeWin10 1507UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.