Library / Sysinternals

whois64.exe

Domain information lookup · Sysinternals - www.sysinternals.com

SysinternalsSysmon-confirmedSigma refs: 1

OriginalFilename

  • whois.exe

Differs from file nameShared with other binaries

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: whois64.exe never fires.
  • Same OriginalFilename as whois.exe, so OriginalFilename alone can't tell them apart.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\whois64.exe'
    - OriginalFileName: 'whois.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
whois.exe1x641.21.0.0Sysinternals✓ 1

InternalName: Whois · Product: Sysinternals Whois

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
0797b9f6e028…1.21.0.0x64whois.exeSysinternals WhoisSysinternals✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.