Library / Windows

wimserv.exe

Wimfltr v2 extractor · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • extractr.exe

Differs from file name

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: wimserv.exe never fires.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\wimserv.exe'
    - OriginalFileName: 'extractr.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
extractr.exe1x6410.0.26100.9711Host scan✓ 1

InternalName: extractr.exe · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
d5d2d3164f4e…10.0.26100.9711x64extractr.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.