Library / Windows

windeploy.exe

Windows Deployment Loader · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • WinDeploy.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\windeploy.exe'
    - OriginalFileName: 'WinDeploy.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
WinDeploy.exe1x6410.0.26100.9549Host scan✓ 1

InternalName: WinDeploy · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
a1dd529a9d7a…10.0.26100.9549x64WinDeploy.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.