Library / Windows

winhlp32.exe

Windows Winhlp32 Stub · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • WINHLP32.EXE

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\winhlp32.exe'
    - OriginalFileName: 'WINHLP32.EXE'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
WINHLP32.EXE1x8610.0.26100.4202Host scan✓ 1

InternalName: WINHSTB · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
ef0e7e43be11…10.0.26100.4202x86WINHLP32.EXEHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.