Library / Windows

winload.exe

OS Loader · Microsoft Corporation

WindowsParsed

OriginalFilename

  • osloader.exe

Differs from file name

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: winload.exe never fires.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\winload.exe'
    - OriginalFileName: 'osloader.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
osloader.exe1x6410.0.26100.9711Host scan

InternalName: osloader.exe · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
621ae8d11424…10.0.26100.9711x64osloader.exeHost scan

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.