Library / Windows

winlogon.exe

Windows Logon Application · Microsoft Corporation

WindowsSysmon-confirmedSigma refs: 6

OriginalFilename

  • WINLOGON.EXE

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\winlogon.exe'
    - OriginalFileName: 'WINLOGON.EXE'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
WINLOGON.EXE18x6410.0.10240.18333 → 10.0.28000.3231Win10 1507 → Win11 26H1 (19)Host scan, Winbindex✓ 1

InternalName: winlogon · Product: Microsoft® Windows® Operating System

All 18 parsed builds · 1 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
1e50cab91e79…10.0.28000.3231x64WINLOGON.EXEWin11 26H1UnsignedWinbindex
2baa43fa3e9b…10.0.26100.9711x64WINLOGON.EXEWin11 24H2UnsignedHost scan, Winbindex✓
efd3511fdb30…10.0.22621.7649x64WINLOGON.EXEWin11 23H2UnsignedWinbindex
edf75701a7b3…10.0.19041.7802x64WINLOGON.EXEWin10 21H2UnsignedWinbindex
493e4bdc3866…10.0.17763.9376x64WINLOGON.EXEWin10 1809UnsignedWinbindex
57b1a58b0255…10.0.14393.9611x64WINLOGON.EXEWin10 1607UnsignedWinbindex
408727849509…10.0.10240.18333x64WINLOGON.EXEWin10 1507UnsignedWinbindex
b0752daabaab…10.0.26100.5074x64WINLOGON.EXEWin11 24H2, Win11 25H2UnsignedWinbindex
4aa0e16a1b7d…10.0.19041.5794x64WINLOGON.EXEWin10 21H2, Win10 22H2UnsignedWinbindex
12b016865048…10.0.22621.5413x64WINLOGON.EXEWin11 22H2UnsignedWinbindex
b4861ff69d5c…10.0.22000.2960x64WINLOGON.EXEWin11 21H2UnsignedWinbindex
24263fe01c79…10.0.19041.2913x64WINLOGON.EXEWin10 20H2 … Win10 22H2 (3)UnsignedWinbindex
6bcb35ba7cdf…10.0.19041.906x64WINLOGON.EXEWin10 2004, Win10 21H1Signed (Catalog file)Winbindex
75de21086ecd…10.0.17134.1345x64WINLOGON.EXEWin10 1803UnsignedWinbindex
865a1ce9edde…10.0.15063.2045x64WINLOGON.EXEWin10 1703UnsignedWinbindex
2ec0d43046ed…10.0.16299.1387x64WINLOGON.EXEWin10 1709UnsignedWinbindex
6cf2dd482973…10.0.18362.693x64WINLOGON.EXEWin10 1903UnsignedWinbindex
24ad1339ad3b…10.0.10586.1356x64WINLOGON.EXEWin10 1511UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.