Library / Sysinternals

winobj.exe

Sysinternals WinObj · Sysinternals - www.sysinternals.com

SysinternalsSysmon-confirmedSigma refs: 1

OriginalFilename

  • WinObj.exe

Shared with other binaries

Gotchas

  • Same OriginalFilename as winobj64.exe, so OriginalFilename alone can't tell them apart.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\winobj.exe'
    - OriginalFileName: 'WinObj.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
WinObj.exe1x863.14.0.0Sysinternals✓ 1

InternalName: WinObj · Product: WinObj

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
c8313c8ea557…3.14.0.0x86WinObj.exeWinObjSysinternals✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.