Library / Windows

winrs.exe

winrs · Microsoft Corporation

WindowsSysmon-confirmedSigma refs: 1

OriginalFilename

  • winrs.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\winrs.exe'
    - OriginalFileName: 'winrs.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
winrs.exe13x64, x8610.0.10240.20747 → 10.0.28000.1Win10 1507 → Win11 26H1 (7)Host scan, Winbindex✓ 2

InternalName: winrs.exe · Product: Microsoft® Windows® Operating System

All 13 parsed builds · 27 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
34cc0a219503…10.0.28000.1x86winrs.exeWin11 26H1UnsignedWinbindex
33ef240641d3…10.0.26100.7019x86winrs.exeWin11 24H2UnsignedHost scan, Winbindex✓
0d4948c4627d…10.0.26100.7019x64winrs.exeWin11 24H2UnsignedHost scan, Winbindex✓
83790021f631…10.0.17763.1x64winrs.exeWin10 1809UnsignedWinbindex
02abc26a1f1f…10.0.17763.1x86winrs.exeWin10 1809UnsignedWinbindex
35d24ffa7a59…10.0.10240.20747x64winrs.exeWin10 1507UnsignedWinbindex
1a56d1b99918…10.0.10240.20747x86winrs.exeWin10 1507UnsignedWinbindex
b1723ab17228…10.0.26100.1150x64winrs.exeWin11 24H2, Win11 25H2Signed (Catalog file)Winbindex
f3cd0fc8e734…10.0.26100.1x86winrs.exeWin11 24H2, Win11 25H2Signed (Catalog file)Winbindex
6d4d5950d1ef…10.0.14393.0x64winrs.exeWin10 1607UnsignedWinbindex
27bdfc7b4733…10.0.14393.0x86winrs.exeWin10 1607UnsignedWinbindex
8f6b0ae69699…10.0.10586.0x64winrs.exeWin10 1511UnsignedWinbindex
1d3bba838a9e…10.0.10586.0x86winrs.exeWin10 1511UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.