Library / Windows

winrshost.exe

Host Process for WinRM's Remote Shell plugin · Microsoft Corporation

WindowsSysmon-confirmedSigma refs: 1

OriginalFilename

  • winrshost.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\winrshost.exe'
    - OriginalFileName: 'winrshost.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
winrshost.exe12x64, x8610.0.10240.20747 → 10.0.28000.1896Win10 1507 → Win11 26H1 (6)Host scan, Winbindex✓ 2

InternalName: winrshost.exe · Product: Microsoft® Windows® Operating System

All 12 parsed builds · 29 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
d8f5e4d75e41…10.0.28000.1896x64winrshost.exeWin11 26H1Winbindex
9beb5d95a34a…10.0.28000.1896x86winrshost.exeWin11 26H1UnsignedWinbindex
2f78b11eb0d4…10.0.26100.7019x86winrshost.exeWin11 24H2UnsignedHost scan, Winbindex✓
21cf8033ed9f…10.0.26100.7019x64winrshost.exeWin11 24H2UnsignedHost scan, Winbindex✓
e3ebb10ab67c…10.0.10240.20747x86winrshost.exeWin10 1507UnsignedWinbindex
9d22b1b5ee16…10.0.10240.20747x64winrshost.exeWin10 1507UnsignedWinbindex
7e05b6137916…10.0.26100.1150x64winrshost.exeWin11 24H2, Win11 25H2Signed (Catalog file)Winbindex
65c3d1e52f44…10.0.26100.1x86winrshost.exeWin11 24H2, Win11 25H2Signed (Catalog file)Winbindex
d3163d97dae3…10.0.14393.0x86winrshost.exeWin10 1607UnsignedWinbindex
607c014a3ca5…10.0.14393.0x64winrshost.exeWin10 1607UnsignedWinbindex
5ea5b79578a1…10.0.10586.0x64winrshost.exeWin10 1511UnsignedWinbindex
11b603e0f55d…10.0.10586.0x86winrshost.exeWin10 1511UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.