Library / Windows

wkspbroker.exe

RemoteApp and Desktop Connection Runtime Broker · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • wkspbroker.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\wkspbroker.exe'
    - OriginalFileName: 'wkspbroker.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
wkspbroker.exe1x6410.0.26100.9549Host scan✓ 1

InternalName: wkspbroker · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
68d0fc709aa8…10.0.26100.9549x64wkspbroker.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.