Library / Windows

wksprt.exe

RemoteApp and Desktop Connection Runtime · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • wksprt.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\wksprt.exe'
    - OriginalFileName: 'wksprt.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
wksprt.exe1x6410.0.26100.9278Host scan✓ 1

InternalName: wksprt · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
43fb57c18e6e…10.0.26100.9278x64wksprt.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.