Library / LOLBin

wlrmdr.exe

Windows logon reminder · Microsoft Corporation

LOLBinWindowsSysmon-confirmedLOLBASSigma refs: 2

OriginalFilename

  • WLRMNDR.EXE

Differs from file name

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: wlrmdr.exe never fires.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\wlrmdr.exe'
    - OriginalFileName: 'WLRMNDR.EXE'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
WLRMNDR.EXE11x6410.0.10240.18818 → 10.0.28000.3086Win10 1507 → Win11 26H1 (15)Host scan, Winbindex✓ 1

InternalName: WLRMNDR.EXE · Product: Microsoft® Windows® Operating System

All 11 parsed builds · 5 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
4d74b95c8ba5…10.0.28000.3086x64WLRMNDR.EXEWin11 26H1Signed (Overlay)Winbindex
9246ba916c40…10.0.26100.9444x64WLRMNDR.EXEWin11 24H2Signed (Overlay)Host scan, Winbindex✓
f2f88477f4e1…10.0.17763.1697x64WLRMNDR.EXEWin10 1809Signed (Overlay)Winbindex
e6f559a6a36c…10.0.14393.4169x64WLRMNDR.EXEWin10 1607Signed (Overlay)Winbindex
97932708ddf9…10.0.26100.5074x64WLRMNDR.EXEWin11 24H2, Win11 25H2Signed (Overlay)Winbindex
2ffead541e08…10.0.10240.18818x64WLRMNDR.EXEWin10 1507Signed (Overlay)Winbindex
2fda95aafb2e…10.0.19041.746x64WLRMNDR.EXEWin10 2004 … Win10 22H2 (5)Signed (Overlay)Winbindex
354b7b5f6d13…10.0.22000.120x64WLRMNDR.EXEWin11 21H2Signed (Overlay)Winbindex
aab35a51217d…10.0.17134.1967x64WLRMNDR.EXEWin10 1803Signed (Overlay)Winbindex
afd7a491842a…10.0.18362.693x64WLRMNDR.EXEWin10 1903Signed (Overlay)Winbindex
9416a55ef689…10.0.10586.0x64WLRMNDR.EXEWin10 1511Signed (Overlay)Winbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.