Library / Windows

wmiadap.exe

WMI Reverse Performance Adapter Maintenance Utility · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • wmicookr.dll

Differs from file nameNames a DLL

Gotchas

  • OriginalFilename names a DLL (wmicookr.dll), not an executable. Rules expecting .exe values miss it.
  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: wmiadap.exe never fires.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\wmiadap.exe'
    - OriginalFileName: 'wmicookr.dll'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
wmicookr.dll2x64, x8610.0.26100.9711Host scan✓ 2

InternalName: wmicookr.dll · Product: Microsoft® Windows® Operating System

All 2 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
d6caaf572b37…10.0.26100.9711x86wmicookr.dllHost scan✓
9419fe3d62f8…10.0.26100.9711x64wmicookr.dllHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.