Library / Windows

wmiapsrv.exe

WMI Performance Reverse Adapter · Microsoft Corporation

WindowsSysmon-confirmedSigma refs: 1

OriginalFilename

  • WmiApSrv.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\wmiapsrv.exe'
    - OriginalFileName: 'WmiApSrv.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
WmiApSrv.exe11x6410.0.10240.17797 → 10.0.28000.3231Win10 1507 → Win11 26H1 (11)Host scan, Winbindex✓ 1

InternalName: WmiApSrv.exe · Product: Microsoft® Windows® Operating System

All 11 parsed builds · 9 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
3d39d1a48b33…10.0.28000.3231x64WmiApSrv.exeWin11 26H1UnsignedWinbindex
119f1db622ce…10.0.26100.9711x64WmiApSrv.exeWin11 24H2UnsignedHost scan, Winbindex✓
d48e526eb3e3…10.0.14393.9611x64WmiApSrv.exeWin10 1607UnsignedWinbindex
44b0d95eea10…10.0.10240.17797x64WmiApSrv.exeWin10 1507UnsignedWinbindex
58ee6e28c645…10.0.26100.5074x64WmiApSrv.exeWin11 24H2, Win11 25H2UnsignedWinbindex
69b65c337c10…10.0.22000.2836x64WmiApSrv.exeWin11 21H2UnsignedWinbindex
700cdc85479c…10.0.17134.1x64WmiApSrv.exeWin10 1803UnsignedWinbindex
2a05ea2653ce…10.0.19041.610x64WmiApSrv.exeWin10 2004UnsignedWinbindex
c1580315758f…10.0.16299.402x64WmiApSrv.exeWin10 1709UnsignedWinbindex
5dd61ed60e35…10.0.15063.1182x64WmiApSrv.exeWin10 1703UnsignedWinbindex
a89817bccbff…10.0.10586.0x64WmiApSrv.exeWin10 1511UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.