Library / Windows

wmprph.exe

Windows Media Player Rich Preview Handler · Microsoft Corporation

WindowsParsedSigma refs: 1

OriginalFilename

  • wmprph.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\wmprph.exe'
    - OriginalFileName: 'wmprph.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
wmprph.exe30x64, x8612.0.10240.18818 → 12.0.28000.1896Win10 1507 → Win11 26H1 (18)Winbindex

InternalName: wmprph.exe · Product: Microsoft® Windows® Operating System

All 30 parsed builds · 4 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
4afe0d529008…12.0.28000.1896x86wmprph.exeWin11 26H1UnsignedWinbindex
056a252bb111…12.0.28000.1896x64wmprph.exeWin11 26H1Winbindex
d36888abf251…12.0.26100.8115x86wmprph.exeWin11 24H2UnsignedWinbindex
315abaa033a0…12.0.26100.8115x64wmprph.exeWin11 24H2UnsignedWinbindex
85300f1075f4…12.0.17763.1697x64wmprph.exeWin10 1809Signed (Catalog file)Winbindex
7e01d6f174c3…12.0.14393.4169x64wmprph.exeWin10 1607UnsignedWinbindex
7d3f580c055c…12.0.14393.4169x86wmprph.exeWin10 1607UnsignedWinbindex
d7fa895ab6e3…12.0.10240.18818x86wmprph.exeWin10 1507UnsignedWinbindex
116257816169…12.0.10240.18818x64wmprph.exeWin10 1507UnsignedWinbindex
aa2682754e81…12.0.26100.1150x64wmprph.exeWin11 24H2, Win11 25H2Signed (Catalog file)Winbindex
8c29a791bb39…12.0.26100.1x86wmprph.exeWin11 24H2, Win11 25H2Signed (Catalog file)Winbindex
da8a4e41b6f2…12.0.22000.653x64wmprph.exeWin11 21H2UnsignedWinbindex
c82ecabfa02c…12.0.22000.653x86wmprph.exeWin11 21H2UnsignedWinbindex
d4bede88fe09…12.0.19041.1266x86wmprph.exeWin10 2004 … Win10 22H2 (4)UnsignedWinbindex
0263d4511b01…12.0.19041.1266x64wmprph.exeWin10 2004 … Win10 22H2 (4)UnsignedWinbindex
c5193cc80dd1…12.0.18362.1832x86wmprph.exeWin10 1909UnsignedWinbindex
0fb5e675ad3a…12.0.18362.1832x64wmprph.exeWin10 1909UnsignedWinbindex
d7807004fc7f…12.0.19041.746x86wmprph.exeWin10 2004, Win10 21H1Signed (Catalog file)Winbindex
6ba2d7103896…12.0.19041.746x64wmprph.exeWin10 2004, Win10 21H1Signed (Catalog file)Winbindex
f4306c0c64fb…12.0.17134.1967x86wmprph.exeWin10 1803UnsignedWinbindex
38ea7cbf313a…12.0.17134.1967x64wmprph.exeWin10 1803UnsignedWinbindex
68091d57a7ba…12.0.15063.2614x86wmprph.exeWin10 1703UnsignedWinbindex
a6b54e71077c…12.0.18362.900x64wmprph.exeWin10 1903UnsignedWinbindex
47a15b4052c3…12.0.18362.900x86wmprph.exeWin10 1903UnsignedWinbindex
e881d9f2bf10…12.0.17763.1282x86wmprph.exeWin10 1809Signed (Catalog file)Winbindex
50c3c5e713ff…12.0.16299.1932x86wmprph.exeWin10 1709UnsignedWinbindex
308958b88e6a…12.0.16299.1932x64wmprph.exeWin10 1709UnsignedWinbindex
15dc7d0567d4…12.0.15063.936x64wmprph.exeWin10 1703UnsignedWinbindex
703d1d96f974…12.0.10586.0x86wmprph.exeWin10 1511UnsignedWinbindex
0cfcf0bd6df1…12.0.10586.0x64wmprph.exeWin10 1511UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.