Library / Windows

wpdshextautoplay.exe

Windows Portable Device Shell Extension Autoplay Handler · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • WpdShExtAutoplay.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\wpdshextautoplay.exe'
    - OriginalFileName: 'WpdShExtAutoplay.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
WpdShExtAutoplay.exe2x64, x8610.0.26100.1301Host scan✓ 2

InternalName: WpdShExtAutoplay.exe · Product: Microsoft® Windows® Operating System

All 2 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
86df7569df45…10.0.26100.1301x64WpdShExtAutoplay.exeHost scan✓
5a3520498a87…10.0.26100.1301x86WpdShExtAutoplay.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.