Library / Windows

wpr.exe

Microsoft Windows Performance Recorder · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • WPR.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\wpr.exe'
    - OriginalFileName: 'WPR.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
WPR.exe1x6410.0.26100.9711Host scan✓ 1

InternalName: WPR.exe · Product: Microsoft Windows Performance Recorder

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
a0d0139d8557…10.0.26100.9711x64WPR.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.