Library / LOLBin

write.exe

Windows Write · Microsoft Corporation

LOLBinWindowsParsedLOLBASSigma refs: 1

OriginalFilename

  • write

Differs from file name

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: write.exe never fires.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\write.exe'
    - OriginalFileName: 'write'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
write7x64, x8610.0.10240.16384 → 10.0.16299.15Win10 1507 → Win10 1709 (4)Winbindex

InternalName: write · Product: Microsoft® Windows® Operating System

All 7 parsed builds · 27 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
97cea2bf66a7…10.0.16299.15x64writeWin10 1709UnsignedWinbindex
ba242dbd6c86…10.0.14393.0x86writeWin10 1607UnsignedWinbindex
7e3485f5edd4…10.0.14393.0x64writeWin10 1607UnsignedWinbindex
e246f2baa27d…10.0.10586.0x86writeWin10 1511UnsignedWinbindex
cc6ab7d0a1ad…10.0.10586.0x64writeWin10 1511UnsignedWinbindex
bd842c6e442d…10.0.10240.16384x86writeWin10 1507UnsignedWinbindex
7765dbb2325a…10.0.10240.16384x64writeWin10 1507UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.