Library / Windows

wscollect.exe

This tool collects Microsoft Store log files · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • WSCollect.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\wscollect.exe'
    - OriginalFileName: 'WSCollect.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
WSCollect.exe1x6410.0.26100.1Host scan✓ 1

InternalName: WSCollect.exe · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
9bf329ab9bea…10.0.26100.1x64WSCollect.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.