Library / LOLBin

wsl.exe

Windows Subsystem for Linux · Microsoft Corporation

LOLBinWindowsSysmon-confirmedLOLBASSigma refs: 13

OriginalFilename

  • wsl.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\wsl.exe'
    - OriginalFileName: 'wsl.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
wsl.exe9x6410.0.16299.1268 → 10.0.28000.2804Win10 1709 → Win11 26H1 (12)Host scan, Winbindex✓ 1

InternalName: wsl.exe · Product: Microsoft® Windows® Operating System

All 9 parsed builds · 3 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
5f42d6dab76f…10.0.28000.2804x64wsl.exeWin11 26H1UnsignedWinbindex
fcd08205b608…10.0.26100.9549x64wsl.exeWin11 24H2UnsignedHost scan, Winbindex✓
979621c38174…10.0.17763.9376x64wsl.exeWin10 1809UnsignedWinbindex
d81dfc0236fa…10.0.26100.5074x64wsl.exeWin11 24H2, Win11 25H2Signed (Catalog file)Winbindex
070f414025d9…10.0.19041.2311x64wsl.exeWin10 20H2 … Win10 22H2 (3)UnsignedWinbindex
54a248353fc7…10.0.18362.1049x64wsl.exeWin10 1903, Win10 1909UnsignedWinbindex
9cae9642354c…10.0.19041.488x64wsl.exeWin10 2004UnsignedWinbindex
17adbca2c889…10.0.17134.885x64wsl.exeWin10 1803UnsignedWinbindex
5781ab4dabcd…10.0.16299.1268x64wsl.exeWin10 1709UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.