Library / Windows

wslconfig.exe

Microsoft Windows Subsystem for Linux Configuration Tool · Microsoft Corporation

WindowsParsed

OriginalFilename

  • wslconfig.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\wslconfig.exe'
    - OriginalFileName: 'wslconfig.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
wslconfig.exe1x6410.0.26100.9278Host scan

InternalName: wslconfig.exe · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
cf9b83ceab84…10.0.26100.9278x64wslconfig.exeHost scan

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.