Library / Windows

wslhost.exe

Microsoft Windows Subsystem for Linux Background Host · Microsoft Corporation

WindowsParsedSigma refs: 2

OriginalFilename

  • wslhost.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\wslhost.exe'
    - OriginalFileName: 'wslhost.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
wslhost.exe5x6410.0.17134.885 → 10.0.19041.1566Win10 1803 → Win10 20H2 (5)Winbindex

InternalName: wslhost.exe · Product: Microsoft® Windows® Operating System

All 5 parsed builds · 6 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
afa8f634ac66…10.0.17763.9376x64wslhost.exeWin10 1809UnsignedWinbindex
fd7a7e771f3d…10.0.19041.1566x64wslhost.exeWin10 20H2UnsignedWinbindex
9b71a406f422…10.0.19041.423x64wslhost.exeWin10 2004UnsignedWinbindex
0585ea461802…10.0.17134.885x64wslhost.exeWin10 1803UnsignedWinbindex
076b4a4006cd…10.0.18362.239x64wslhost.exeWin10 1903UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.