Library / Windows

wsmanhttpconfig.exe

WSMan HTTP Configuration File · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • WSManHTTPConfig.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\wsmanhttpconfig.exe'
    - OriginalFileName: 'WSManHTTPConfig.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
WSManHTTPConfig.exe2x64, x8610.0.26100.9444Host scan✓ 2

InternalName: WSManHTTPConfig.exe · Product: Microsoft® Windows® Operating System

All 2 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
d68ca28a53a7…10.0.26100.9444x86WSManHTTPConfig.exeHost scan✓
05d918936210…10.0.26100.9444x64WSManHTTPConfig.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.