Library / Windows

wudfhost.exe

Windows Driver Foundation - User-mode Driver Framework Host Process · Microsoft Corporation

WindowsSysmon-confirmedSigma refs: 1

OriginalFilename

  • WUDFHost.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\wudfhost.exe'
    - OriginalFileName: 'WUDFHost.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
WUDFHost.exe10x6410.0.10240.21161 → 10.0.28000.3231Win10 1507 → Win11 26H1 (12)Host scan, Winbindex✓ 1

InternalName: WUDFHost.exe · Product: Microsoft® Windows® Operating System

All 10 parsed builds · 8 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
3c6d332a8c92…10.0.28000.3231x64WUDFHost.exeWin11 26H1Signed (Overlay)Winbindex
0780aef80d43…10.0.26100.9711x64WUDFHost.exeWin11 24H2Signed (Overlay)Host scan, Winbindex✓
62c949c18805…10.0.17763.9376x64WUDFHost.exeWin10 1809UnsignedWinbindex
eab59553aecd…10.0.14393.8519x64WUDFHost.exeWin10 1607UnsignedWinbindex
2d97146e7fdf…10.0.26100.5074x64WUDFHost.exeWin11 24H2, Win11 25H2Signed (Overlay)Winbindex
3a8f266c8d0d…10.0.10240.21161x64WUDFHost.exeWin10 1507UnsignedWinbindex
28cb4ebd5994…10.0.19041.1865x64WUDFHost.exeWin10 20H2 … Win10 22H2 (3)UnsignedWinbindex
bb4dd2c216c7…10.0.18362.2158x64WUDFHost.exeWin10 1909UnsignedWinbindex
007712752e50…10.0.15063.0x64WUDFHost.exeWin10 1703UnsignedWinbindex
22bb28675ffa…10.0.10586.0x64WUDFHost.exeWin10 1511UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.