Library / Windows

wusa.exe

Windows Update Standalone Installer · Microsoft Corporation

WindowsSysmon-confirmedSigma refs: 3

OriginalFilename

  • wusa.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\wusa.exe'
    - OriginalFileName: 'wusa.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
wusa.exe22x64, x8610.0.10240.20793 → 10.0.28000.2804Win10 1507 → Win11 26H1 (14)Host scan, Winbindex✓ 2

InternalName: wusa.exe · Product: Microsoft® Windows® Operating System

All 22 parsed builds · 14 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
8d159a5fe481…10.0.28000.2804x86wusa.exeWin11 26H1UnsignedWinbindex
09d55bdc7814…10.0.28000.2804x64wusa.exeWin11 26H1Winbindex
7a6443c12bac…10.0.26100.9549x64wusa.exeWin11 24H2UnsignedHost scan, Winbindex✓
061864be3228…10.0.26100.9549x86wusa.exeWin11 24H2UnsignedHost scan, Winbindex✓
d64ed632f753…10.0.17763.9376x64wusa.exeWin10 1809UnsignedWinbindex
a2e946607bcc…10.0.14393.7330x86wusa.exeWin10 1607UnsignedWinbindex
1dd6f40f1e3b…10.0.14393.7330x64wusa.exeWin10 1607UnsignedWinbindex
8b5b60cb0498…10.0.10240.20793x86wusa.exeWin10 1507UnsignedWinbindex
3acf28b5d9bf…10.0.10240.20793x64wusa.exeWin10 1507UnsignedWinbindex
d11263419e73…10.0.26100.5074x64wusa.exeWin11 24H2, Win11 25H2UnsignedWinbindex
83c6db1e42b6…10.0.26100.5074x86wusa.exeWin11 24H2, Win11 25H2UnsignedWinbindex
984971b13f89…10.0.22000.653x64wusa.exeWin11 21H2UnsignedWinbindex
7df1359f8b32…10.0.22000.653x86wusa.exeWin11 21H2UnsignedWinbindex
6097b96e5526…10.0.19041.1741x86wusa.exeWin10 20H2 … Win10 22H2 (3)UnsignedWinbindex
36768f5caa1d…10.0.19041.1741x64wusa.exeWin10 20H2 … Win10 22H2 (3)UnsignedWinbindex
ccda2c9e74e5…10.0.19041.1151x86wusa.exeWin10 2004 … Win10 21H2 (3)Signed (Catalog file)Winbindex
b74ef7da9512…10.0.15063.1155x86wusa.exeWin10 1703UnsignedWinbindex
77160a147be1…10.0.15063.1155x64wusa.exeWin10 1703UnsignedWinbindex
0887d01d26d6…10.0.10586.589x64wusa.exeWin10 1511UnsignedWinbindex
ba63b908b60f…10.0.10586.0x86wusa.exeWin10 1511UnsignedWinbindex
64101be948b3…10.0.16299.15x64wusa.exeWin10 1709UnsignedWinbindex
5d1fe9338a8f…10.0.16299.15x86wusa.exeWin10 1709UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.