Library / LOLBin

xwizard.exe

Extensible Wizards Host Process · Microsoft Corporation

LOLBinWindowsSysmon-confirmedLOLBASSigma refs: 1

OriginalFilename

  • xwizard.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\xwizard.exe'
    - OriginalFileName: 'xwizard.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
xwizard.exe10x64, x8610.0.10240.16384 → 10.0.28000.1896Win10 1507 → Win11 26H1 (6)Host scan, Winbindex✓ 2

InternalName: xwizard.exe · Product: Microsoft® Windows® Operating System

All 10 parsed builds · 28 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
b3e5dd6aaca9…10.0.28000.1896x86xwizard.exeWin11 26H1UnsignedWinbindex
163ee8ebb931…10.0.28000.1896x64xwizard.exeWin11 26H1Winbindex
a2f98c9de026…10.0.26100.1882x64xwizard.exeWin11 24H2, Win11 25H2Signed (Catalog file)Host scan, Winbindex✓
4cc4f132d514…10.0.26100.1882x86xwizard.exeWin11 24H2, Win11 25H2Signed (Catalog file)Host scan, Winbindex✓
aea911646713…10.0.14393.0x64xwizard.exeWin10 1607UnsignedWinbindex
16065d6fa950…10.0.14393.0x86xwizard.exeWin10 1607UnsignedWinbindex
b8d916182ccc…10.0.10586.0x86xwizard.exeWin10 1511UnsignedWinbindex
380cac47a146…10.0.10586.0x64xwizard.exeWin10 1511UnsignedWinbindex
b0e481b39810…10.0.10240.16384x64xwizard.exeWin10 1507UnsignedWinbindex
1d9284fd7818…10.0.10240.16384x86xwizard.exeWin10 1507UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.